Menú Principal

Este sitio usa cookies y tecnologías similares.

Si no cambia la configuración de su navegador, usted acepta su uso. Saber más

Acepto

Zona descarga

Joomla! 2.5. ¿Qué versión instalar? ¿1.5, 1.6, 1.7 o 2.5?

Tamaño de letra:

Lanzamiento de Joomla! 2.5. Soporte a largo plazo.

Hoy, 24 de enero de 2012, por fin tenemos la esperadísima versión estable de Joomla! 2.5. Una versión de soporte a largo plazo (LTS - Long Term Support) cuyo soporte comienza hoy y termina en diciembre de 2013. Veremos las novedades que trae y responderemos a una de las preguntas que los más iniciados desconocen y no me importa volver a repetir una y otra vez. ¿Eres nuevo? ¿Sabes las diferencias de las versiones 1.5, 1.6, 1.7 y 2.5 y cuál debes instalar?. Te las vamos a explicar.

Tras el lanzamiento de la versión 3.0 el 27 de septiembre de 2012, hemos realizado un nuevo artículo: Instalar Joomla! 1.5, 2.5 o 3.

Este lanzamiento, estable y preparado ya para usar en tu sitio en producción, es el resultado de miles de horas de trabajo de cientos de voluntarios y lo más importante es que cumple exactamente los plazos descritos en la estrategia de desarrollo de Joomla! (http://developer.joomla.org/strategy.html). Esto es muy importante, y hace que este CMS atraiga cada día a más usuarios.

Las 3 versiones de Joomla!. Cuál instalar.

Para los que no conocéis Joomla! y estáis en proceso de comenzar a utilizarlo, debéis saber que a día de hoy (24 de enero de 2012) existen 3 versiones de Joomla!. Sí, lo sé, es raro pero existen 3 versiones y se debe al punto anterior de la estrategia de desarrollo. Os las voy a explicar. El primer lugar donde os debéis dirigir para entender esto, es a la página oficial de Joomla! donde verás el estado actual de desarrollo: http://developer.joomla.org/development-status.html. Hoy puedes ver que hay 3 versiones, pero el principal problema que tienen, es el soporte. El soporte es IMPORTANTÍSIMO y significa que cuando termine dicho tiempo, no habrá actualizaciones de ningún tipo –por ejemplo de seguridad, que son las más importantes- y si sigues con esa versión tu sitio podrá quedar expuesto a riesgos. Joomla! está en desarrollo continuo y siempre tendrás que ir actualizándolo. Debes entender una cosa y es que en estas 3 versiones se siguen principalmente dos líneas de desarrollo:

  • Joomla 1.5: Que ahora tiene la versión 1.5.25. Observa que no tiene futuro, es un callejón sin salida.
  • Joomla 1.6 – 1.7 – 2.5: Que es donde tienes que estar. Como puedes ver, actualizar de 1.6 a 2.5 es sencillo, pero no de 1.5 a 1.6, porque en J 1.6 hubo un salto enorme y no se puede actualizar directamente, hay que migrar todo. Si eres nuevo tu versión es la 2.5.

Las 3 versiones que existen hoy son (si sigues la estrategia de desarrollo verás que dentro de poco serán solo 2):

  • Joomla 1.7.4: Es una versión de soporte a corto plazo, pero como está en la línea de desarrollo que he explicado antes, puedes actualizar a la 2.5 de forma sencilla. Tiene soporte hasta febrero de 2012, sin embargo, como no todas las extensiones son compatibles todavía con la versión 2.5, pero lo van a ser en muy breve tiempo algunos usuarios tendrán que mantener esta versión algunos días más.
  • Joomla 2.5: Hoy ha sido su lanzamiento oficial y es la continuación de Joomla 1.7, como he explicado. En el siguiente párrafo hablaré sobre sus novedades.
  • Joomla 1.5.25: Es una versión donde se ve, desde hace mucho tiempo, el final. Es un callejón sin salida. Tiene los días contados y soporte hasta abril de 2012, aunque parece ser que se corregirán graves errores de seguridad hasta la versión 3.0, a finales del mismo año. Si vas a empezar a crear tu web, NO LO USES, y el que diga lo contrario está mintiendo. Aún a día de hoy recibo correos respecto al uso o no de Joomla! 1.5.

¿Por qué repito a los usuarios que empiezan que no lo usen? Pues porque si hoy instalas Joomla! 1.5 en un futuro tendrás que migrar a Joomla! 2.5 o Joomla! 3.0 o el que sea (porque si no no podrás tener actualizaciones de ningún tipo, sobre todo seguridad y testeado por millones de usuarios), y dicha migración es un trabajo que puede llegar a ser bastante desbordante (según tu web y la gente que trabajéis en ella). De hecho todas las páginas actuales que trabajan con Joomla! 1.5 tendrán que migrar a Joomla! 2.5 en breve si no quieren quedar vulnerables.

Lanzamiento de la nueva versión 2.5

Hoy se ha producido el lanzamiento de la nueva versión de Joomla! 2.5 y trae muchísimas novedades y características extra. Como podemos ver en esta noticia de su página oficial, trae nuevas características como la búsqueda avanzada y la notificación automática de actualizaciones de Joomla y extensiones. Por primera vez, Joomla! incluye soporte para múltiples bases de datos con la adición de Microsoft SQL Server. Las versiones anteriores sólo eran compatibles con bases de datos MySQL.

Comentarios de Mark Dexter. Novedades.

Mark Dexter, líder del equipo de producción de Joomla!, comenta:

“Hemos recibido, literalmente, miles de sugerencias en ideas.joomla.org en lo que se debe agregar a la funcionalidad de Joomla 2.5, y por una abrumadora mayoría, las notificaciones y las búsquedas más elegantes encabezaron la lista.”

Esta versión es la siguiente actualización desde la versión 1.7 y contiene una serie de novedades:

  • Se han añadido 26 nuevas características
  • Se han reparado 4 problemas de seguridad
  • Se han reparado 356 problemas de seguimiento.

Todas estas novedades y corrección de problemas están detalladas aquí: http://www.joomla.org/announcements/release-news/5403-joomla-250-released.html

Descarga

Podemos descargar esta nueva versión 2.5 desde aquí: http://www.joomla.org/download.html

Última actualización: Sábado, 29 Septiembre 2012

Comentarios   

0 # javier 12-10-2012 19:53
yo tampoco estoy de acuerdo en lo que #ZeRoXSaaPY dice. Ademas el video q pones dice que afecta a estas versions: "Joomla 1.6.x Joomla 1.7.x Joomla 2.5.0 Joomla 2.5.1 Joomla 2.5.2"
y di te fijas veraas q la ultima versin de joomla es la 2.5.7

Yo tampoco instalo ya la 1.5 como te han dicho quedara sinsoporte
espero haberte ayudado
Responder | Responder con una citación | Citar
0 # #ZeRoXSaaPY 12-10-2012 16:24
Me parece increible que digan que joomla 2.5 es mas segura que la 1.5 siendo que se han descubierto vulnerabilidade s criticas en esta version de joomla y para la muetsra un boton http://www.youtube.com/watch?v=kiVfu88mpDA, y esta vulnerabilidad NO afecta la 1.5 yo me quedo con la 1.5 por ahora hasta que las demas versiones sean estables y seguras y ustedes cual escogeran ? .....
Responder | Responder con una citación | Citar
0 # karmadmin 12-10-2012 17:33
Joomla! tiene un equipo específico para encontrar vulnerabilidade s. Además cientos de miles de personas comentan sus propios problemas.
El equipo de Joomla! NO dará soporte en breve a la versión 1.5.x y no se corregirán errores.
¿Sabes la migración que hay que hacer para pasar de J!1.5 a J!3.x? Si tú tuvieras una empresa seguro que no instalarías J!1.5 a tus clientes. Además el desarrollo de Joomla! está ya en la serie 3.x (aunque en soporte a corto plazo todavía) y los desarrolladores de extensiones no creo que sientan especial predilección por crear su software para una versión como la J!1.5.x ya que no es el futuro.
Desde mi punto de vista, tarde o temprano habrá que migrar a la última versión (de eso se trata, de mejorar ¿no?). En todo caso te tocará a ti programar y corregir vulnerabilidade s en el core de este CMS o en sus extensiones.
¿Hay segura al 100% una web? Yo creo que no y aunque la tengas con Joomla! 1.5.x o 3.x o 40.x alguien puede encontrar una vulnerabilidad y te la pueden hackear, nadie se puede salvar de esto.
Para evitar vulnerabilidade s hay que estar actualizado a la última versión estable.

De todos modos, creo que en esta web nunca se ha hecho la comparación de que joomla 2.5 es más segura 1.5 (creo que nunca he dicho esto y si lo he dicho me he equivocado). Lo único que se ha dicho es que Joomla! 1.5.x dejará de tener soporte y que si vas a crear tu web desde cero que no lo uses por todo lo que acabo de decir.

No veo correcto que digas a la gente que si va a crear una web que instale la v.1.5.x no me parece correcto porque les obligarás a hacer una migración que a mí me dió muchos dolores de cabeza.

Muchas gracias por tu comentario.
Responder | Responder con una citación | Citar
+1 # Enrique Leon 08-10-2012 14:15
ESTOY CANSADO DE JOOMLA. Empece con la versión 1.0, no tengo el tiempo necesario para estar instalando nuevas versiones y cada año toca estar migrando a otra versión. A que hora mejora uno el contenido?. POR FAVOR DEJEN UNA SOLA VERSION ESTABLE POR LO MENOS 3 AÑOS. GRACIAS
Responder | Responder con una citación | Citar
0 # Javier 08-10-2012 15:03
Yo pienso igual, Enrique. Para los que tenemos menos tiempo y conocimientos es incómodo estar todo el tiempo pendiente de actualizaciones.
Por ese motivo, a partir de la versión 1.6 (creo recordar) se creo la estrategia de desarrollo para que estas migraciones de las que tú hablas sean mínimas y parece ser que lo serán.
Pero estoy de acuerdo en lo que dices y te entiendo. Imagina ahora que tienes una empresa y necesitas instalar una versión de soporte a corto plazo que cada mes hay que instalar una nueva versión...
Responder | Responder con una citación | Citar
0 # cediel 06-10-2012 23:21
tengo un sitio en 1.5.23 y ahora en el hosting me ofrecen la 2.5 y la 3.0 que hago, cual instalo?
como las actualizo?
Responder | Responder con una citación | Citar
0 # karmany 07-10-2012 00:48
Como se explica en el artículo, puedes instalar cualquiera de las dos.
Si instalas la versión 2.5 en la primavera de 2014 tendrás que migrar a la versión 3.5, pero hasta entonces puedes perfectamente usar la 2.5.

Comprueba si la versión 3.0 es lo que buscas y tiene actualizadas las extensiones que necesitas porque la versión 3.0 no es compatible con todas las extensiones de la 2.5.

Puedes instalar cualquiera de las dos, pero haz pruebas primero.
Responder | Responder con una citación | Citar
0 # cediel 06-10-2012 23:20
tengo un sitio en 1.7, puedo instalar la 3.0 y cargarle la base de datos y listo... o necesito algo mas para actualizarlos
Responder | Responder con una citación | Citar
0 # karmany 07-10-2012 00:50
La versión 1.7 es de la serie 2.x que son: la versión 1.6, 1.7 y 2.5. Si tu sitio tiene Joomla! 1.7 puedes pasar sin ningún problema a Joomla! 2.5 simplemente actualizando con el archivo correspondiente.
Pero seguramente tendrás problemas con la actualización a Joomla! 3.0 porque hay que modificar la template y algunas extensiones no son compatibles.
Responder | Responder con una citación | Citar
0 # Sin nombre 15-07-2012 22:45
12 de julio de 2012
Se anuncia el lanzamiento de Joomla! 3.0.0 ALPHA 1, solo para testear. El lanzamiento de la versión estable estará disponible supuestamente para el 24 de septiembre de 2012...
La versión ALPHA 2 estará disponible en breve tiempo, sobre el 23 de julio, según su web:
developer.joomla.org/news/503-joomla-3-0-alpha-1-released
Responder | Responder con una citación | Citar

Escribir un comentario

Antes de publicar un comentario, usted debe aceptar nuestras condiciones de uso: Condiciones de uso


 
Visitas: 4842758